You are not logged in.

[Tipp] Performance verbessern

Antworten im Thema: 45 » Der letzte Beitrag (Mar 26th 2013, 12:19am) ist von SudelNuppe.

Dear visitor, welcome to Trucksimulator24 - Die freundliche Trucksimulator Community rund um den Euro Truck Simulator 2, Euro Trucksimulator, German Truck Simulator, 18 Wheels of Steel Reihe, Extreme Trucker und den ZModeler.. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Candlejack

Unregistered

11

Friday, November 25th 2011, 2:38pm

Drei Probleme

Hallo Truckerfreunde,

ich habe (bisher... kommen vlt. noch mehr) drei Probleme mit dem Tutorial, welches im überigen sehr gut geschrieben wurde.

1.:

Quoted

Wichtig, setzt nach dem Speichern der Cofing diese auf "Schreibgeschützt".
Wenn ich das mache lässt sich GTS nicht mehr starten.
Ich erhalte dann die Fehlermeldung, das "game.exe" nicht mehr funktioniert und werde zum Desktop zurück geworfen.

2.: Ich habe mal EasyToolz mit der CPU Affinity ausprobiert, jedoch bleibt die "Aktiv-LED" von dem Programm bei mir Rot, wenn ich das Spiel gestartet habe.

Ich habe Windows Server 2008 (beruht auf dem Vista Kernel, gibt also keine Probleme beim Spielen) und das GTS auf 1.32 gepatched.

3.: Ich spiele das Spiel mit dem Driving Force GT Lenkrad von Logitech und habe bemerkt, dass das Gas-geben und das manuelle Hochschalten manchmal hakt.
Zudem stellen sich die Settings wie Deadzone jedesmal, wenn ich den Task z.B. zum Browser und wieder ins Spiel wechsel zurück, so dass ich die Deadzone und das Force Feedback wieder neu einstellen muss.

Hat jemand ähnliche Probleme und vlt. eine Lösung dazu gefunden?

Lieben Gruß,
Candlejack

[Edit:] Da fällt mir noch ein... Ich habe das Notepad (Taste N) auf eine der Tasten vom Lenkrad gelegt, was soweit auch funktioniert. Jedoch lässt es sich mit der Taste nur Öffnen und zum Schließen muß ich immer die ESC-Taste nehmen. Kann man das auch so einrichten, dass ich das auch wieder mit der Taste vom Lenkrad schließen kann?

Zudem hat mein Sound manchmal Aussetzer z.B. beim Gasgeben. Das ist etwas nervig....
Hardwarebeschleunigung beim Sound ist aus.

[Edit_2:]
Das mit der ESC-Taste habe ich nun im Logitech Profiler eingestellt und klappt.
Die Hardwarebeschleunigung für den Sound lässt sich gar nicht deaktivieren. Wenn ich "germantrucks.exe" starte, diese deaktiviere, das Setup-Programm beende und nochmal neu starte ist die Option automatisch wieder aktiviert...

This post has been edited 3 times, last edit by "Candlejack" (Nov 25th 2011, 4:00pm)


diverbaer

Unregistered

12

Friday, November 25th 2011, 4:46pm

meine frage mal dazu:
hast du zufällig mal wegen dem schlafmodus an der game .exe herum gefingert????

Candlejack

Unregistered

13

Friday, November 25th 2011, 4:52pm

Nein.
Habe nur das "Harrys Map 3.5" Mod drin.
Also folgende vier Dateien:
  • zzzZ_HarrysMap_Map&Defs.scs
  • zzzZ_HarrysMap_Model.scs
  • zzzZ_HarrysMap-Sonstiges.scs
  • zzzZZZzzz_ats_flares.scs

Ich muss das zusagen, dass ich auch erst seit heute spiele... :)

Harry Piel

Unregistered

14

Friday, November 25th 2011, 5:11pm

@Candlejack: Du hast geschrieben, dass Du Probleme mit dem Tutorial hast. Hast Du denn auch Probleme mit dem Spiel? Darüber konnte ich aus Deinen Zeilen nichts lesen.

Candlejack

Unregistered

15

Friday, November 25th 2011, 5:21pm

Die Probleme werden weniger... :)
Nachdem ich nun via dem Sysinternals Process Explorer dem Spiel beide Kerne zugewiesen habe (mit EasyToolz ging es ja nicht) läuft es flüssiger, hakt aber noch ab und an.

Die Soundprobleme nerven im Moment noch am meisten, da ich mit Kopfhörer spiele und der Sound mal von links nach rechts springt oder selbst auch hakt.
Und das ich die Steuerung nach jedem Alt-Tab wieder neu einstellen muss.

diverbaer

Unregistered

16

Friday, November 25th 2011, 5:30pm

versuch doch mal in der game option die einstellungen etwas runter zu stellen... statt alles auf hoch... mal auf mittel oder wenn nicht sogar auf niedrig.... bringt auch noch etwas... schont dazu auch noch den grafikspeicher und prozessor...

Harry Piel

Unregistered

17

Friday, November 25th 2011, 6:44pm

Damit das Spiel etwas zügiger läuft, lade Dir mal die korrigierte Version ( http://www.megaupload.com/?d=KRO1FU8L ) der Map herunter. In dieser Version ist der sonstige Verkehr (AI) herausgenommen, da zu viele Modelle mit hoher Auflösung drinne waren, die erheblich an der Performance geknabbert haben.

2 registered users thanked already.

Users who thanked for this post:

BlackPanther257, Otte64

Candlejack

Unregistered

18

Friday, November 25th 2011, 7:07pm

Danke für den Tipp.
Sind dann keine AI Autos mehr im Spiel?
Das wäre nicht so prickelnd, da ich finde, dass eh schon so wenig Verkehr zu sehen ist.
Ich freue mich eigentlich immer, wenn ich mal mehr als 3 Autos sehen darf :) .
Hatte sogar schon einen kleinen Ministau auf der Bahn *freu* :D .
Mit der Performance bin ich soweit recht zufrieden, von daher sollte es an den Autos eigentlich nicht liegen und ich glaube nicht, dass das was mit dem Sound zu tun hat.
Es hat bei mir echt viel ausgemacht, wenn ich das Spiel auf zwei Prozessorkernen laufen lasse (s.o.).
Kommt mir eher so vor, als würde dem Spiel zu wenig Kanäle zur Verfügung stehen, bzw. die von den Entwicklern nicht richtig genutzt werden.
Ich werde das mal in der config bei der "s_mix_channels"-Einstellung testen.
Gibt es ein empfehlenswertes Soundmod?
Denn der LKW-Sound ist allgemein viel zu leise und auch nicht wirklich so der Hit.

Tolles Mod überigens, Harry Piel!!!
Wenn ich auch das Spiel selbst ohne Mods kaum gespielt (ca. 3h zum Üben) habe und es bisher das einzige ist, was ich ausprobiert habe :)

Teddybaer

Unregistered

19

Friday, November 25th 2011, 7:14pm

Danke für den Tipp.
Sind dann keine AI Autos mehr im Spiel?
Das wäre nicht so prickelnd, da ich finde, dass eh schon so wenig Verkehr zu sehen ist.
Ich freue mich eigentlich immer, wenn ich mal mehr als 3 Autos sehen darf :) .
Hatte sogar schon einen kleinen Ministau auf der Bahn *freu* :D .
Mit der Performance bin ich soweit recht zufrieden, von daher sollte es an den Autos eigentlich nicht liegen und ich glaube nicht, dass das was mit dem Sound zu tun hat.
Es hat bei mir echt viel ausgemacht, wenn ich das Spiel auf zwei Prozessorkernen laufen lasse (s.o.).
Kommt mir eher so vor, als würde dem Spiel zu wenig Kanäle zur Verfügung stehen, bzw. die von den Entwicklern nicht richtig genutzt werden.
Ich werde das mal in der config bei der "s_mix_channels"-Einstellung testen.
Gibt es ein empfehlenswertes Soundmod?
Denn der LKW-Sound ist allgemein viel zu leise und auch nicht wirklich so der Hit.

Wenn Du den AI-Verkehr rausnimmst hast insgesamt weniger Verkehr.Aber Du wirst dich wundern was der Ai-Verkehr mit der Leistung zu tun hat.Ergo viel Verkehr gleich viel Rechnerleistung ;) Das wird kaum was mit dem Sound zu tun haben.Was allerdings diesen betrifft,guck mal durch unseren Downloadbereich,wir haben da einiges,aber da sollte Dein persönlicher Geschmack entscheiden ;)
Das Spiel wurde für Einkerntechnologie entwickelt,da kannst halt nix dran ändern :)

KingScania

King of the Road

  • "KingScania" is male
  • »KingScania« is a verified user

Posts: 1,023

Location: Ulm

wcf.user.option.userOption105: Windows 7 Home Premium 64bit

wcf.user.option.userOption107: Euro Truck Simulator 2

wcf.user.option.userOption106: 1.22.4.2s

Thanks: 3301

  • Send private message

20

Friday, November 25th 2011, 7:20pm

Nabend^^
Hab die meisten Tipps davon probiert, nur an einem scheiterts, nämlich GTS auf zwei Kernen laufen zu lassen. Ich hab nen Doppelkern mit 2,1Ghz pro Kern, aber wenn ich die Zugehörigkeit festlegen will, kommt folgende Meldung:

KAnn man da iwas machen oder muss ich mich damit zufrieden geben?

MfG KingScania :)


1 user apart from you is browsing this thread:

1 guests

Social bookmarks

Counter:

Hits today: 46,761 | Hits yesterday: 77,740 | Hits record: 302,395 | Hits total: 124,149,812 | Average hits: 35,535.95

Clicks today: 115,024 | Clicks yesterday: 147,512 | Clicks record: 756,082 | Clicks total: 556,633,967 | Clicks avarage: 159,327.82 | Counts since: May 3rd 2011, 7:40am

Ungelesene Beiträge Unbeantwortete Themen Themen der letzten 24 Stunden

Euro Truck Simulator,Euro Truck Simulator 2,German Truck Simulator,Forum,Community,Downloads,Support,Euro Trucksimulator,Euro Trucksimulator 2,German Trucksimulator,Trucks,18 Wheels of Steel,Haulin,Convoy,Pttm,Long Haul,Trucksimulator,Trucksimulation,Truck Simulator,Simulation,ATS,Trucksim,Extreme Trucker 2,ETS,ETS2,GTS,UKTS,ET,ET2,18WoS,Tutorial,Tutorials,Tipp,Zmodeler,z3d,Modding,SCS,simulation,support, Zmod,z3d,Sk,Skins,Map,Maps,Mod,Mods,Trucksims,STD,Scania Truck Driving Simulator,Scania,ETS2Mods, Euro Trucksimulator2 Mods